As of February 5, 2008, new versions of the Gavintech Framework will require PHP 5.2 or higher. We support the GoPHP5 initiative to eliminate PHP4 from the Internet.

Old, stable versions of the Gavintech Framework (version 1.0.x) will be exempt from this initiative, as the code was released before February 5, 2008. Given the frequency of releases of the Gavintech Framework, it is likely that version 1.1 will be the first to require PHP 5.2. Gavintech Framework 1.1 will include a database abstraction layer, and many other new and improved features.

If you'd like to use newer versions of the Gavintech Framework, you should encourage your web host to upgrade to PHP 5.2 or above before February 5, 2008. The best way to convince people to switch is to have many major projects and web hosts set a deadline for migrations.

For more details about the Gavintech Framework itself, go to about the Gavintech Framework. To see the Framework in action, explore this page (which is run by the Framework), the Brentwood College Theatre ticket booking site, the University of Victoria helpdesk tools page, or the Gavintech production version.